NewsML-G2 2.36

Preview. Generated from the NewsML-G2 2.36 XML Schema by tools/xsdref. This layout is a harness for reviewing structure and content — it is not the published site.

i18nAttributes

An attribute group. Elements listing it carry every attribute below.

Note
Usage note

Notes:

  • xml:lang values MUST follow RFC 4646 and RFC 4647 (as both replace RFC 3066) or its successor. See also IETF BCP47.

  • The dir qualifier specifies the directionality of scripted text: left-to-right (“ltr”, the default) or right-toleft (“rtl”). Its definition follows the XHTML 1.0 production. Directionality – left-to-right or right-to-left – is assigned to characters in Unicode, in order to allow the text to be rendered properly. For example, while English characters are presented left-to-right, Hebrew characters are presented right-to-left. Unicode defines a bidirectional algorithm that must be applied whenever a document contains right-to-left characters. While this algorithm usually gives the proper presentation, some situations leave directionally neutral text and require the dir attribute to specify the base directionality.

Attribute Type Use Description

xml:lang

optional

Specifies the language of this property and potentially all descendant properties. xml:lang values of descendant properties override this value. Values are determined by Internet BCP 47.

dir

optional

The directionality of textual content (enumeration: ltr, rtl)

Carried by

<a>, <access>, <accessStatus>, <accountable>, <action>, <affiliation>, <altId>, <area>, <assert>, <assignedTo>, <audience>, <bag>, <broader>, <by>, <capacity>, <catalogItem>, <concept>, <conceptExtProperty>, <conceptItem>, <conceptRef>, <contentMeta>, <contentMetaExtProperty>, <contributor>, <copyrightHolder>, <copyrightNotice>, <country>, <creator>, <creditline>, <dataMining>, <dateline>, <definition>, <deliverableOf>, <deliveredItemRef>, <derivedFrom>, <description>, <details>, <digitalSourceType>, <edNote>, <eventStatus>, <exclAudience>, <facet>, <facetConcept>, <generator>, <genre>, <group>, <groupExtProperty>, <headerExtProperty>, <headline>, <infoSource>, <inline>, <inlineData>, <inlineRef>, <inlineXML>, <instanceOf>, <itemClass>, <itemMeta>, <itemMetaExtProperty>, <itemRef>, <keyword>, <knowledgeItem>, <line>, <link>, <locality>, <located>, <location>, <mainConcept>, <memberOf>, <metadataCreator>, <name>, <narrower>, <newsCoverageExtProperty>, <newsCoverageStatus>, <newsItem>, <note>, <occurStatus>, <openHours>, <organiser>, <packageItem>, <partMeta>, <partMetaExtProperty>, <participant>, <participationRequirement>, <party>, <planningExtProperty>, <planningItem>, <postalCode>, <profile>, <promptInfo>, <promptWriter>, <provider>, <pubStatus>, <publishedExtProperty>, <registration>, <related>, <remoteContentExtProperty>, <remoteInfo>, <rightsInfo>, <rightsInfoExtProperty>, <role>, <ruby>, <sameAs>, <schemeMetaExtProperty>, <service>, <signal>, <slugline>, <span>, <subject>, <system>, <title>, <type>, <usageTerms>, <worldRegion>